Press "Enter" to skip to content

Ruby on Rails 5

 

สวัสดีครับ วันนี้ผมมาอัพเดทเกี่ยวกับ Ruby on Rails เวอร์ชั่นที่กำลังจะออกมาใหม่ก็คือ version 5  ส่วนตัวผมเขียน framework นี้มาได้ไม่นานนัก ก็จะสามารถแนะนำได้ระดับนึง ตามภาษาคนที่เขียน Ruby on Rails version 4

สำหรับสิ่งที่จะแนะนำก็คือ การเปลี่ยนแปลงหลักๆ ดังนี้

  • การรวมเอา Rails API มาอยู่ใน Ruby on Rails 5
  • คุณจะสามารถใช้ Ruby on Rails 5 ได้จะต้องใช้ Ruby ตั้งแต่ 2.2.1 ขึ้นไป
  • ใน Ruby on Rails 5 มาพร้อมกับ turbolinks 3 ถ้าใครยังไม่รู้จัก มันคือตัวที่ช่วยในการใช้งาน JS ใน Ruby on Rails
  • Active Cable คือ Web Socket ที่ใช้ในการทำ Stream ข้อมูลต่างๆ ให้กับ Front-end
  • rake inside rails คือ ต่อไปเราจะสามารถใช้ rails db:migrate แทน rake db:migrate
  • Active record จะฉลาดขึ้นนิดหน่อย (ลองอ่านเพิ่มเติมได้)
  • อื่นๆ

และสามารถติดตามอ่านเพิ่มเติมได้ที่ What’s new Rails 5

Arnon Hongklay
Arnon Hongklay

View all posts